Ikool’s Blogbed

Compatibility issue of Thickbox and jQuery in WordPress when both NextGen Gallery and WP e-commerce present

Both jQuery and Thickbox have different versions, and WordPress and its plugins may use different versions of jQuery for different plugins since plugin engineers basically work on their parts without paying much attentions to others’. I checked my installation of WordPress 2.5.1 and it has jQuery 1.2.3 and Thickbox 3.1. However, when you install other plugins which might use a fairly new jQuery such as 1.2.4, what happens in this case is they conflict, some of the features may not work at all, such as Fix of issues with old version of jQuery in WordPress 2.5.1 when using FeedWordPress. In the case of having both NextGen Gallery and WP e-commerc, you may even see what I saw as depicted in this image. The problem gets even worse when the plugins are using Thickbox because different versions of Thickbox will only work perfectly with their corresponding versions of jQuery:

Continue reading

Advertisements

June 14, 2008 Posted by | Wordpress Plugins, Wordpress Tips, WP E-Commerce | , , , , , , , , | 9 Comments